CA Workload Automation DE: Externals do not run as per run frequency of application
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CA Workload Automation DE: Externals do not run as per run frequency of application

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Article ID: 140363

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Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

When external jobs use the application default run frequency, they will not run when event is triggered or show up if event is simulated.

Environment

Release : 12.1, 12.2

Component : CA WORKLOAD AUTOMATION DE (DSERIES)

Cause

The issue may be related to invalid XML tags.  The application may have been migrated from older version such as 11.3.

The schedule tags for the jobs may be empty or have null character.  This will result in DE not resolving the invalid tags for the job(s).


E.g.

<scheduled> </scheduled>




Resolution

To fix the issue:

 

1. Open the job, uncheck "Use Application-level defaults"  

2. Next, click on the "Show in Calendar"

3.  In the Calendar, select a date and click Close.

4.  Check the "Use Application-level defaults" again

5.  Save and upload the application

6.  Simulate the event.

 

Additional Information

Note:   If the above steps does not resolve issue, then delete and re-create the job and save the application.

              Use the CA WA Desktop client R12.1 or above.

              Do not manually edit the XML tags.