Bad Security Handshake Errors
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Bad Security Handshake Errors

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Article ID: 140283

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

Both smps.log and smtracedefault.log show repeated messages similar to these:

  1. Bad security handshake attempt. Handshake error: 3159
  2. Handshake error: Failed to receive client hello. Client disconnected
  3. Failed handshake with ##.###.###.##:54492
  4. Handshake error with trusted host  with IP ##.###.###.## on Port No 54492

What is the cause of these messages

Environment

Release : 14.3

Component : IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

This behavior can occur when integrated products perform periodic health checks or when a load balancer closes connections due to session timeout settings. Load balancers commonly initiate health checks that do not complete a full handshake, which can result in these messages.

Resolution

If the SSO is working as expected, this message can be ignored.