Remote VSE unable to start: Cannot register with the DevTest Registry timeout
search cancel

Remote VSE unable to start: Cannot register with the DevTest Registry timeout

book

Article ID: 140223

calendar_today

Updated On:

Products

CA Application Test Service Virtualization

Issue/Introduction

When trying to start a VSE that is remote to the registry, the VSE fails to start with this message in the vse.log: 
ERROR com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl - Cannot register with the DevTest Registry [Unable to add incoming VSE with a service name of tcp://vseserver:2013/VSE - connection timed out after 5000 milliseconds.]

The registry.log showed: 

ERROR com.itko.lisa.coordinator.TestRegistryImpl - Unable to add incoming VSE with a service name of tcp://vseserver:2013/VSE - connection timed out after 5000 milliseconds.

This means the Registry received the connection request from the VSE but cannot connect back to the VSE server using IP address for the VSE server and port 2013

 

 

Environment

All supported DevTest releases.

Cause

The Registry received the connection request from the VSE but cannot connect back to the VSE server using IP address for the VSE server and port 2013

Running ping to the VSE server on the registry server confirmed that there was a problem to connect to the IP address:

ping vseserver

"Time to live Exceeded"

Resolution

The problem was resolved after configuring the hostname of the VSE server in vmoptions with:

-Dlisa.vseName=tcp://vseserver:2013/VSE

Additional Information

See the following document for requirements regarding TCP network connectivity between DevTest components:

Environmental Restrictions and Communication issues