ADA / CAPC Sync Error: Column 'AGG_NAME' cannot be null

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Article ID: 140215

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Updated On:

Products

CA Application Delivery Analysis MTP (NetQoS / ADA) CA Application Delivery Analysis (NetQoS / ADA) APPLICATION DELIVERY ANALYSIS SUPERAGENT

Issue/Introduction

While using ADA with CAPC you may run into a sync issue. If you check the D:/CA/SuperAgentSync logs, you may see: Column 'AGG_NAME' cannot be null

Cause

A group without a name in CAPC could cause issues.

Environment

Component : NQSAMC - NETQOS SA MGMT CONSOLE

Resolution

Remove the dubious group:


mysql netqosportal

select * from t_group where ItemName='';


The groups should be dubious. Remove the group by doing a delete as long as you are sure that the group is dubious. 


Contact Broadcom Support if you have any doubts.

Additional Information

Similar issues could affect UCM. You may see errors in the UCMWebService logs where a group fails to sync due to the name being 'null'. This fix will resolve this issue for UCM as well.