CA PPM Jaspersoft Apply Button Not working with Phoenix Theme

book

Article ID: 140211

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Apply button in the input control not working in the input control of jaspersoft .
 
 
Error from screen shot is from debugging: Phoenix UI Version {PUI_Version}:
Failed to load resource: The server responded with a status of 403 (Forbidden)
 
Apply button doesn't work, and the only error is the one displayed in developer tools. Message "You must apply input values before the report can be displayed." shows even though input values were selected. 

Cause

If the Siteminder web agent finds a bad character, it will reject the request.

Environment

Release : 15.5.1

Component : CA CLARITY PPM Jaspersoft

Resolution

If using CA Siteminder 


Please perform the following:


A) Check the Webagent logs for Siteminder


B) In the logs will define as "Bad Character"


C) In the Siteminder configuration file, remove the Bad Character

Additional Information

For more information please see the below document:


1) Override the Default CSS Character Set

2) Specify Bad Query Characters

3) Specify Bad URL Characters

4) Enable Bad Form Characters


https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-identity-and-access-management/single-sign-on/12-52-01/configuring/web-agent-configuration/user-protection-and-tracking/help-prevent-attacks.html#concept.dita_a4f1c9b394b5b45650256db5105c5886a242345b_SpecifyBadURLCharacters