Resources cannot login into the Clarity via LDAP authentication when "%20" string is used

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Article ID: 140185

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

  • Resources are imported via LDAP with the following root context:

OU=something,OU=String1 String2,DC=something,DC=something

  • Since one of the Organisational Units (OU) has a space, LDAP sync jobs fails and we can only make the job to succeed using a workaround that involves replacing the space character with "%20" string.

For example : OU=something,OU=String1%20String2,DC=something,DC=something

  • However, with the "%20" fix, the users can't login into the Clarity via LDAP authentication. They can only log in when we remove the "%20" character from the Organisational unit (OU) string.

Cause

  • This is because the LDAP cannot interpret the '%20' in the Root Context.

Environment

Release : 15.6, 15.7

Component : CA PPM INTEGRATIONS & INSTALLATIONS

Resolution

If resources want to login into Clarity using LDAP authentication, then the '%20' characters must be removed from Organisational Units (OU) string as per current product design.

 

 

Additional Information

https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=136560