Integration of DX SaaS with ServiceNow

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Article ID: 140173

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Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

ServiceNow is IT Operations Management (ITOM):
 
 
SN will not allow DX SaaS access to the Incidents table, only the Events table. Our SN Ticket Management Channel claims to need access to the Incidents table, and that will not be permitted.
 
Please update the Channel to create Events, not Incidents.
 
Right now APM sends SNMP traps to a SN server on prem  and Events are created from those traps. That will not be possible for SaaS.
 
SN can ingest Events via REST API, SNMP Trap (on-prem only), and, as a last resort, email. 
 
It's the ServiceNow Channel:
 
 

Cause

Per Engineering,  customer is looking for Snow integration to create events in Snow instead of incidents for APM alerts through AIOPs SaaS solution. 

If yes, engineering recommends to use the webhook integration supported in channels section to create events in Snow ( or SaaS instance) and if Snow is on-prem, we can leverage On-Prem gateway solution.

Environment

Release : SAAS

Component : CA APM SAAS ESSENTIALS

Resolution

Customer decided to get ServiceNow to configure a webhook for the DX SaaS channel.