Post timesheet: ****POSTTIMESHEET: Couldn't post time entry

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Article ID: 140154

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After running the Post Tiemsheet job, I see there is an approved timesheet that is not moving to the Posted status
Looking at bg-ca.log file, we see the following error:
ERROR 2019-10-16 16:04:29,377 [Dispatch pool-5-thread-10 : myPPMuser (tenant=clarity)] xql2.xbl (clarity:myuser:86301970__A09EC2EB-5DE9-4106-B399-27924200EAE4:Post Timesheets) ****POSTTIMESHEET: Couldn't post time entry-->timesheetID=5116383; timeEntryID=6549261; assignmentID= 

Cause

There is a data integrity issue where an orphan record exists

Resolution

Select * from PRTIMEENTRY where prtimesheetid = 5116383 (The ID is taken form the log message)

Note the data returned


Affected prtimentry row

Select * from PRTIMEENTRY where prid = 6549261


Ensure that the data returned on the first query, has got a matching record at the PRASSIGNMENT and the PRTASK tables.

Additional Information

On This specific case, the issue was due to a missing row at the PRTASK table.

We had an assignment record, that did not have a referenced entry on the PRTASK table.

The timesheet was showing 9 tasks in the UI and at DB level on the PRASSIGNMENT table we had 10 rows, 1 being orphan.


If you are facing this scenario, please contact support.


Please also check:


I am having problems to post a specific timesheet. What could be the reasons?

articleId=140155