APM - Query about Severity and Status options in Message Template

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Article ID: 140111

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Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

In the documentation, https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/application-performance-management/11-1/administrating/configure-your-monitoring-environment/create-notifications-for-alerts.html, Status has 3 values (status – the severity of the alert (OK, CAUTION, DANGER)). 

When we configure this in the Message Template (${Severity}, ${Status}), the value of Status comes as New, Updated and Closed. Severity comes as Normal, Major and Critical.

Can you help us explain this discrepancy.

Cause

status – the severity of the alert (OK, CAUTION, DANGER)
This is for the REST API of APM. It retrieves Alert info from APM directly. So this is the APM native Alert Status field.

Message Template is part of DXI, which has its own native Status field already. The Severity field is a mapped field of APM Alert Status.
OK -> Normal
CAUTION -> Major
DANGER -> Critical

So the Native Status values for Message Template are New, Updated, Closed.

Environment

Release : SAAS

Component : APM SAAS ENTERPRISE

Resolution

status – the severity of the alert (OK, CAUTION, DANGER)
This is for the REST API of APM. It retrieves Alert info from APM directly. So this is the APM native Alert Status field.

Message Template is part of DXI, which has its own native Status field already. The Severity field is a mapped field of APM Alert Status.
OK -> Normal
CAUTION -> Major
DANGER -> Critical

So the Native Status values for Message Template are New, Updated, Closed.