NFA System Status Errors Services listed as stopped, unknown or Unreachable Status
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NFA System Status Errors Services listed as stopped, unknown or Unreachable Status

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Article ID: 139940

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA) CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After a new installation of NFA you may see NetOps Portal System Status messages like:

In the legacy views you will see:

"The Pump Service Service's current state is stopped."

"The General Service Service's current state is stopped."

"The Report Service's current state is stopped."

"The RIB Service's current state is stopped."

"The SSO Service's current state is stopped."

"The Harvester Service's current state is Unknown"

"The Proxy Service's current state is Unknown"

"The Poller Service's current state is Unknown"

"The Reaper Service's current state is Unknown"

"The SNMP Service's current state is Unknown"

"The Web Server Service's current state is Unknown"

"The Collector/Poller WS Service's current state is Unknown"

"The Data Retention Service's current state is Unknown"

"CPU Usage is unknown"

"Memory Usage is Unknown"

Environment

NFA all versions

Cause

SNMP community string

Resolution

The System Status messages come from SNMP polls of each server and mysql checks from the NetQos ReporterAnalyzer Watchdog service on the console.

You need to make sure the Windows SNMP service on the Console and the Harvesters have the same community string as set on the Admin->Watchdog (legacy NFA) setting page of NFA, the default is Public. For the post-flash browsers this must be done from the NetOps Portal. Go to Administration > Data Sources > Network Flow Analysis > Watchdog Settings. 

You can check this on the Windows SNMP Service's Security tab, make sure the same SNMP community string is listed as above.  

 

Also make sure to set either "Accept SNMP packets from any host" or "Accept SNMP Packet from these hosts" and list the IP address of the NFA Console server.  If the Console server has multiple IP addresses.

 

Check if the Community String was changed in NFA Database:

Log on on NFA Console Server, open the command prompt and run:
mysql -unetqos -pnetqos
use reporter
select * from parameter_descriptions where Parameter = 'watchdogCommunity';
select * from system_settings where Parameter = 'watchdogCommunity';
 
If not change with this query:
update parameter_descriptions set DefaultValue = "public" where Parameter = "watchdogCommunity";
update system_settings set Value = "public" where Parameter = "watchdogCommunity";
 
Check again:
select * from parameter_descriptions where Parameter = 'watchdogCommunity';
select * from system_settings where Parameter = 'watchdogCommunity';
 
Note: Change the "public" to the correct Community Name if necessary

 

Once that is set properly, you can try restarting the Netqos ReporterAnalyzer Watchdog Service and wait a few minutes and check again.

You must also ensure that ports 161 and 3308 are open between the NFA Console and all Harvesters.

Note that the Harvester side messages about "Update time is 0" is normal until those harvesters start collecting data.

 

Additional Information

If everything is configured correctly and you still are seeing the messages above please see: 

NFA Admin->System Status Page shows errors from Watchdog Service but the configuration is correct