Symantec Directory : After upgrading to 14.1.07, DXagent fails to start (Windows)
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Symantec Directory : After upgrading to 14.1.07, DXagent fails to start (Windows)

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Article ID: 139898

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Updated On:

Products

CA Directory

Issue/Introduction

You may experience a problem of DXagent not able to start after upgrading to 14.1.07 version from a previous Service Pack on Windows.

1. Either get error message pop up-

Can't create output file:

C:\.\..\dxserver\dxagent\python-embed-amd64\lib\site-packages\win32\servicemanager.pyd

2. Or the dxagent process fails to terminate after the install is done until manually killed. This can be seen in Windows Task Manager.

Reviewing the log, you may see:

Python could not import the service's module
Traceback (most recent call last):

File "C:\Program Files\CA\Directory\dxserver\dxagent\DxagentService.py", line 23, in <module>

import win32serviceutil

File "C:\Program Files\CA\Directory\dxserver\dxagent\python-embed-amd64\lib\site-packages\win32\lib\win32serviceutil.py", line 9, in <module>

import win32service, win32api, win32con, winerror

ImportError: No module named 'win32service'

Environment

Release : 14.x

Component : CA Directory

Cause

 The DXagent component in the Environment might be corrupted. 

Resolution

 The DXagent component in your Environment might be corrupted. To update the DXagent files, follow the manual steps outlined below.

First is to manually extract the missing files from the DATA1.cab in the installer. This file is located under the location where you extracted the zip file (usually under temp folder).

Copy to data1.cab to a separate folder and extract the content using WinZip or equivalent software.

The Data1.cab contains a file which starts with ca_dxagent_static.exe (e.g. something like ca_dxagent_static.exe.B5FA3F68_D6E0_4F16_9C6F_B0C63D712195). This file holds the DXagent related files. Once you have it, follow the steps below.

  • Take a backup of existing %DXHOME%\dxagent folder.
  • Close applications like Event Viewer, if they are running.
  • From the Data1.cab file extract the file with the name that starts with ca_dxagent_static.exe (e.g. something like ca_dxagent_static.exe.B5FA3F68_D6E0_4F16_9C6F_B0C63D712195).
  • Create a new folder and copy the file ca_dxagent_static.exe.B5FA3F68_D6E0_4F16_9C6F_B0C63D712195 in that folder
  • Rename the file ca_dxagent_static.exe.B5FA3F68_D6E0_4F16_9C6F_B0C63D712195 to ca_dxagent_static.exe
  • Open a command prompt (as an administrator) and cd to the created folder where ca_dxagent_static.exe is located.
  • Run this command: ca_dxagent_static.exe /auto .
  • The above command will extract the necessary DXagent files. 
  • Copy all the files in the current folder to the original/existing %DXHOME%\dxagent folder.

         Note: Some files need to be replaced. Select yes to replace the files.

  • From the backup taken in step 1 above, copy the dxagent/dxagent_config.py file back to existing/original %DXHOME%\dxagent folder.
  • From the backup taken in step 1 above, copy the dxagent/openssl-ca folder back to existing/original %DXHOEM%\dxagent folder.
  • Go to the %DXHOME%\dxagent\doc\fonts folder
  • Run this command: ca-dxagent-font-static.exe /auto .
  • From Windows Services Panel, DXagent should be able to start successfully now.

         Note: If there is any issue with the certificates, run the setup_dxagent.bat file to create new certificates.