After upgrading Spectrum with BMP Patch, Jaspersoft Reports are extremely slow
search cancel

After upgrading Spectrum with BMP Patch, Jaspersoft Reports are extremely slow

book

Article ID: 139847

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading Spectrum with the latest BMP patch, we are now unable to run reports in Jaspersoft as it takes 10 minutes for the Input Parameters Page to load up and when it does load, it is completely blank.

Environment

Release : 10.2.x, 10.3.x, 10.4.x

Component : Spectrum Report Manager (SRM)

Jaspersoft  6.3, 6.4.3



Cause

Reports have been updated in the BMP release but there is an issue with the redeploy.  Suggest to perform a clean redeploy of the reports in Jaspersoft.

Resolution

Steps to perform a clean redeploy of all Jaspersoft Reports


1. Stop JasperServer Tomcat

2. Login to OC and navigate to

   Administrator -> Report Manager -> Jasper Integration Page

3. Disable the SSO and Jaspersoft Integration. 

4. Download the latest spectrumConfigInstaller.jar into Jasper Server by clicking on Integration components.

5. Move/delete existing SpectrumProxy.war and SpectrumProxy/ to another folder outside of the $CABI_Install path from $CABI_Install path/tomcat/webapps

6. Run the downloaded Jar file java -jar spectrunConfigInstaller.jar -install on the Jasper sever from the correct path

<CABI Install folder path>\java\bin\java -jar <spectrumConfigInstaller.jar file path>\spectrumConfigInstaller.jar -install

Example: <CABI Install folder path>\java\bin\java -jar C:\Users\Admin\Downloads\spectrumConfigInstaller.jar -install

7. Start JasperServer Tomcat

8. Once the Jasper is up and running, Enable Integration and SSO then perform 'Re-deploy' from the Jasper Integration page.

9. Try to run a single report and see if it is still slow, if so proceed to step 10.

10. Run "java -jar spectrunConfigInstaller.jar -rs" from the correct path:

<CABI Install folder path>\java\bin\java -jar <spectrumConfigInstaller.jar file path>\spectrumConfigInstaller.jar -rs

Example: <CABI Install folder path>\java\bin\java -jar C:\Users\Admin\Downloads\spectrumConfigInstaller.jar -rs

11. Try to run the reports again and all should be correct.