Table '.\reporting\sm_resourcecauses' is marked as crashed in Spectrum Report Manager (SRM) reporting database
search cancel

Table '.\reporting\sm_resourcecauses' is marked as crashed in Spectrum Report Manager (SRM) reporting database

book

Article ID: 139846

calendar_today

Updated On:

Products

Spectrum Network Observability

Issue/Introduction

The $SPECROOT/tomcat/logs/stdout.log (Windows) or catalina.out (Linux) file is huge with thousands of this entry:

java.sql.SQLException: Table '.\reporting\sm_resourcecauses' is marked as crashed and should be repaired

Environment

Release : Any
Component : Spectrum Report Manager

Cause

The sm_resourcecauses table in the reporting database is corrupted.

Resolution

NOTE: In the following MySql commands, replace <PASSWD> with the root password for your DX NetOps Spectrum version.

- Log into the SRM system as the user that own the Spectrum installation

- If on Windows, start a bash shell by running "bash -login"

- cd to the $SPECROOT/mysql/bin directory and enter the following command:

./mysqlcheck --defaults-file=../my-spectrum.cnf --repair -uroot -p<PASSWD> reporting sm_resourcecauses

- Restart tomcat