Agent was automatically up/down graded to previous version
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Agent was automatically up/down graded to previous version

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Article ID: 139826

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

After a manual upgrade of an Agent, it (magically) starts as the previous version.

Environment

Release : 12.0.x, 12.1.x, 12.2.x, 12.3.x, 21.x

Component : Unix, Windows or RA Agent

Cause

The Agent was automatically “repaired”, meaning upgraded or downgraded, to the latest version that corresponds to Centralized Agent Upgrade pack. 

Scenario (example):

  1. Agent was upgraded with CAU from 12.0.6 to 12.0.8.
  2. Agent was then manually downgraded to 12.0.6
  3. As soon as the agent was started (12.0.6) it automatically upgraded to 12.0.8 - in this case in the Upgrade History of system client 0000 the entries titled "REPAIR" will show up to indicate that the agent was repaired by a forced upgrade.

Scenario 2:

  1. Agent was upgraded with CAU from 12.3.6 to 12.3.8.
  2. Agent was then manually upgraded to 21.0.4
  3. As soon as the agent was started (21.0.4) it automatically downgraded to 12.3.8 - in this case in the Upgrade History of system client 0000 the entries titled "REPAIR" will show up to indicate that the agent was repaired by a forced upgrade.

When an Agent has started, the AE checks in the database what the Target version of the Agent is. The following SQL statement shows this field:

select HOST_TargetVersion from HOST,OH where OH_idnr=HOST_OH_Idnr and OH_name='<AGENT_NAME>'

Resolution

According to the documentation, if the CAU has been already successfully performed for an agent and the agent connects to the AE with a wrong target version subsequently, the CAU is repeated.

This means an upgrade is forced to bring the agent to the last target version that was selected in the last CAU action.

In this case in the Upgrade History of system client 0000 the entries titled "REPAIR" will show up to indicate that the agent was repaired by a forced upgrade to the desired target version.

 

How to Revert to a Previous Version:

 

You may want to revert the agent's upgrade in case your preferences or system occurrences make it seem appropriate.

This function is technically an upgrade to another agent version.

Therefore you just have to follow the steps described above for the CAU itself.

 

Alternatively, you can upgrade the Agent manually and use the option Skip Upgrade, so the CAU is not executed.

 

For a full explanation, see here: https://docs.automic.com/documentation/webhelp/english/ALL/components/DOCU/21.0.4/Automic%20Automation%20Guides/Content/Installation_Upgrade/install_cau_procedure.htm