Error from Workstation: Connection to the registry database cannot be established. Please make sure the database is running and the credential used to the database is valid. 
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Error from Workstation: Connection to the registry database cannot be established. Please make sure the database is running and the credential used to the database is valid. 

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Article ID: 13981

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

How do I troubleshoot this error from Workstation when connecting to a remote Registry:

Connection to the registry database cannot be established. Please make sure the database is running and the credential used to the database is valid. 

If you continue, data will not be saved to the database. Do you want to continue? 

 

Environment

All supported DevTest releases and platforms.

Cause

Workstation could not access database Registry is connecting to.

All DevTest components must be able to connect to the external database the Registry is connecting to.

Resolution

Needed to open access on the Workstation machine to the Registry external database.

 

 

Additional Information

BEST PRACTICES for DevTest Database Troubleshooting

 

Example:

A Workstation was connecting to a remote Registry that is targeting a MySQL database.

In the workstation.log, saw this error:

Access denied for user 'root'@'localhost" (using password: YES) 

It seems MySQL is picky about using localhost.

Changed the lisadb.pool.common.url in the site.properties file of where the Registry was to connect to the actual machine name and not localhost and was then able to get past the error. 

This is just one example on how using these two properties can help troubleshoot database issues with DevTest.