AWI timeout when open multiple connections to AE - All sessions expired at the same time.
search cancel

AWI timeout when open multiple connections to AE - All sessions expired at the same time.

book

Article ID: 139587

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When open 5 or 6 AWI sessions, it will be timeout. Error messages can be "session expired" or "communication problem".
Issue can be reproduced by:
 - login to 5 AE clients via AWI (5 tabs in Chrome). 
 - After few minutes, when open the 6th AWI connection (6th tab in Chrome), session expired appeared in all 6 AWI sessions.

Environment

Release : 12.2

Component : AUTOMATION ENGINE

Cause

This issue is because of non-supported version of Tomcat v8.5:


29-Oct-2019 07:05:05.821 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server version: Apache Tomcat/8.5.24

29-Oct-2019 07:05:05.821 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server built: Nov 27 2017 13:05:30 UTC

29-Oct-2019 07:05:05.821 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server number: 8.5.24.0


Under AWA 12.2.X, officially only Tomcat 7 and Tomcat 8 are supported, but not 8.5.


Chrome fallbacks to long pooling and blocks the communication with the other tabs.



Resolution

Use a supported version of Tomcat.