Admin Console not working after upgrading UIM: Unable to read configuration
search cancel

Admin Console not working after upgrading UIM: Unable to read configuration

book

Article ID: 139526

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The Admin Console GUI is no longer working after the recent upgrade of UIM.

When we open any GUI of any probe we get the below error:

Unable to Read configuration. Configuration was unable to be retrieved. Server Replied: (CA UIM Server - Page Not Found)

 

Environment

Release : UIM 20.x.x

Component : WASP / Adminconsoleapp

Cause

File Corruption / non reproducible

Resolution

1) Deactivate the admin console wasp

 

2) redeploy to the adminconsole wasp robot the following probes in their latest version in the archive:

 

- adminconsoleapp 
- ppm
- mps
- mpse
- wasp

 


3) restart the robot where the admin console wasp is (if it's your primary hub restart the primary hub)

 


4) start the wasp 

 


5) clear browser cache memory and browse to:

 <uimserver>/adminconsoleapp/

 

Additional Information

This procedure may also fix the scenario where, after an upgrade, the wasp probe does not start at all on the primary hub with error:

Controller: Max. restarts reached for probe 'wasp' (command = <startup java>)