After OS Patching and server reboot unable to start up database
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After OS Patching and server reboot unable to start up database

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Article ID: 139482

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

We patched our RHEL server and encountered a verticadb start up issue. 


/opt/vertica/bin/adminTools -t start_db -d drdata -p <pasword> -i

Unable to read database catalogs - cannot start database.

Database drdata did not start successfully: Unable to read database catalogs



Environment

Dx NetOps Performance Management any version 

Cause

Vertica reads the catalog in order to know all the specifics of the database, including where to find the data.


The mount points for /data and /catalog are getting reversed on reboot.

/data contains the catalog files and /catalog contains the data files.

Resolution

Have the system admin fix the mounts.

Possible issues with san indexing, as this should never happen.

Evidence of this may be seen in /var/log/messages files on the data repository nodes