Users are not able to access SRM Preferences or Archive Expert Pages
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Users are not able to access SRM Preferences or Archive Expert Pages

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Article ID: 139471

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Updated On:

Products

CA Spectrum

Issue/Introduction

Users are not able to access SRM Preferences or Archive Expert Pages


If you check either of the following tomcat logs (depending on the OS) you may see the following error:


Windows: <SPECROOT>/tomcat/logs/stdout.log

Linux: <SPECROOT>/tomcat/logs/catalina.out


Error:


java.lang.NoSuchMethodError: org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate(Ljava/lang/String;Ljava/lang/Class;Ljavax/servlet/jsp/PageContext;Lorg/apache/jasper/runtime/ProtectedFunctionMapper;Z)Ljava/lang/Object;

at org.apache.jsp.repmgr.admin.preferences_jsp._jspx_meth_c_005fif_005f0(preferences_jsp.java:253)

at org.apache.jsp.repmgr.admin.preferences_jsp._jspService(preferences_jsp.java:122)












Environment

Release : 10.3.x, 10.4.x


Cause

There is a conflict within the .jar files on the Spectrum Report Manager server.

Resolution

Delete the <SPECROOT>/tomcat/work directory from the Spectrum Report Manager server. Then stop and restart the Spectrum Tomcat process. This restart will re-create this directory and resolve the issue.