After successfully installing an External Connector Server it is failing to register via the External Tools User Interface (UI) on the CA Identity Suite Virtual Appliance (vAPP).
Same issue might happen in IGA Xpress v15 -showing unable to register CCS, unreachable or when trying to create endpoint using this Remote CCS log or VST shows:
Endpoint '<endpoint name>' creation failed: Unable to connect to Connector Server: ldaps://<Remote CCS IP>:20403
Release : 14.X and up
Component : Identity Suite
Windows firewall on the Connector Server is blocking communication from the Provisoning Server.
Suggested ports to allow through windows firewall if you cannot disable it:
20402 - CCS non-SSL
20403 - CCS - SSL
20410 - JCS - non SSL (14.X only)
20411 - JCS - SSL (14.X only)
4104 - CAM UDP port
4105 - CAM TCP port
22001 - Broker HTTP Port
22002 - Broker HTTPS Port
20080 - Web Console HTTP Port
20443 - Web Console HTTPS Port
22099 - RMI Registry Port
Full port refference can be found here.
Only as a test you may disable windows firewall to make sure it was a problem: