Failed to connect: No master daemon was detected. The SM DLL cannot initialize.: SmInitialize
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Failed to connect: No master daemon was detected. The SM DLL cannot initialize.: SmInitialize

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Article ID: 139337

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Updated On:

Products

CA Client Automation CA Client Automation - IT Client Manager

Issue/Introduction

Start of CAF is failing with error :

Failed to connect: No master daemon was detected. The SM DLL cannot initialize.: SmInitialize

In DSM\logs\TRC_CF_CFSMSMD_0.log following error appears :


CFSMSMD   |DSM-FIPS140     |DSM-FIPS140         |000000|INFO   | CAPKI Init: CAPKI Path(./)

CFSMSMD   |DSM-FIPS140     |DSM-FIPS140         |000000|INFO   | CAPKI Init: CRYPTO Path(./)

CFSMSMD   |InitComp        |InitComp            |000000|ERROR  | Failed to init CBB!

CFSMSMD   |CFSMCAPI        |CFSMCAPI            |000000|ERROR  | LoadIdentityComponent : Failed to initialise cert/enc support

Environment

Client Automation - All supported versions

Cause

This problem could occur if an old version of DLL cbbcore.dll is found before one stored in SC\CBB

Use following command to find cbbcore.dll found using PATH variable :

 

where /T cbbcore.dll

In example above old version cbbcore.dll is found in DSM\bin directory

Resolution

Delete the old file cbbcore.dll.

In example above, the file C:\Program Files (x86)\CA\DSM\Bin\cbbcore.dll should be deleted.