Spectrum OneClick WebApp return error SPC-OCC-10251 can't connect to localhost:443
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Spectrum OneClick WebApp return error SPC-OCC-10251 can't connect to localhost:443

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Article ID: 139111

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The OneClick WebApp fails to start with an error "SPC-OCC-10251 Can't connect to localhost:443"

Environment

Release : 21.2, 22.2

Component : Spectrum Core / SpectroSERVER

Cause

The Main Arguments -host parameter in the WebApp configuration was set to localhost, instead of the hostname of the OneClick server, and the JVM_ARGUMENTS referenced the incorrect path to the correct keystore.

Resolution

  1. Open a browser and navigate to the following URL:

https://<ocserver>:9443/spectrum.

     2. Click on the "Manage' link in the upper right hand corner.

     3. Click on the "Show Config" link on the upper right hand corner of the view.

     4. Find the "MAIN Arguments" setting and make sure the -host parameter references the correct hostname of the OneClick server.

     5.  As Oneclick is using ssl, the -ssl parameter must be set to yes, and the ssl port must be set to the correct value. Next is an example for Windows:

Main Arguments: -host localhost -port 80 -ssl false -contextPort 43000 -compress 9

changed to

Main Arguments: -host <oneclick_hostname> -port 443 -ssl true -contextPort 43000 -compress 9

     6. Find the "JVM ARGUMENTS" setting and make sure the path to the keystore files are correct. Next is an example for Windows:

JVM Arguments: -Xmx1024m -Djavaws.cfg.jauthenticator=true -Dsun.awt.noerasebackground=true 

changed to

JVM Arguments: -Xmx1024m -Djavaws.cfg.jauthenticator=true -Dsun.awt.noerasebackground=true -Djavax.net.ssl.trustStore=C:/win32app/Spectrum/custom/keystore/cacerts -Djavax.net.ssl.trustStorePassword=changeit

     7. Restart the Spectrum WebTomcat service.