No alarms seen in the Alarms tab of Spectrum OneClick
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No alarms seen in the Alarms tab of Spectrum OneClick

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Article ID: 139090

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

No alarms seen in the Alarms tab of Spectrum OneClick

Environment

Release : Any version of Spectrum

Component : Spectrum Core / SpectroSERVER

Cause

Possible root causes:

 

1. No connection from the SpectroSERVER system(s) to port 14001 on the OneClick server

 

The SpectroSERVER system passes the alarm information to the OneClick system on port 14001 on the OneClick system. When you run "netstat -an | grep 14001" on the OneClick system, you should see one entry for LISTEN and one for an ESTABLISHED connection to the SpectroSERVER system. For example:

# netstat -anop | grep 14001

tcp        0      0 x.x.2.1:38662           x.x.2.2:14001           ESTABLISHED

tcp        0      0 :::14001                    :::*                        LISTEN



2. The SpectroSERVER is busy with something else and is not able to send the alarm information to OneClick

Resolution

If the issue is with no connection from the SpectroSERVER to OneClick on port 14001, check to verify there are no firewall rules preventing the communication.


To check if the issue is with the SpectroSERVER is busy:


On Linux, as the root user, run "pstack <SS_PID>" (where <SS_PID> is the process id of the SpectroSERVER process)


On Windows, download procdump and run procdump on the SpectroSERVER process


Look at thread 1 to determine what the SpectroSERVER is doing during this time and investigate.


For example, if you see "search" in thread 1, it could be a "Real Time" update Global Collection search or if you have a trap based Southbound Gateway integration, the SpectroSERVER is receiving a lot of traps for the integration.


Contact Spectrum Support if assistance is needed analyzing the pstack/procdump information.