CA Performance Management (CAPM) Data Collector partition running out of space and causing data loss
search cancel

CA Performance Management (CAPM) Data Collector partition running out of space and causing data loss

book

Article ID: 138932

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

DC is running very slowly and graphs in CAPC are missing data. 

 

Environment

CAPM 3.5

Cause

When looking at the DC, the file system is full:

# df -h

/dev/mapper/ehealth-CA 44G   40G  1.3G  97% /opt/CA
# du -a /opt/CA | sort -n -r | head -n 10

41840876 /opt/CA

41840856 /opt/CA/IMDataCollector

40937984 /opt/CA/IMDataCollector/apache-karaf-2.4.3

30607076 /opt/CA/IMDataCollector/apache-karaf-2.4.3/dcdebug

30607072 /opt/CA/IMDataCollector/apache-karaf-2.4.3/dcdebug/On-Demand-Log

8517704 /opt/CA/IMDataCollector/apache-karaf-2.4.3/data

5122932 /opt/CA/IMDataCollector/apache-karaf-2.4.3/data/log

3298060 /opt/CA/IMDataCollector/apache-karaf-2.4.3/data/karaf.out

2964312 /opt/CA/IMDataCollector/apache-karaf-2.4.3/data/log/Exception.log.2

1520392 /opt/CA/IMDataCollector/apache-karaf-2.4.3/data.bak

Resolution

The space may be taken up by DCDEBUG logging located under: 

 /opt/CA/IMDataCollector/apache-karaf-2.4.3/dcdebug/On-Demand-Log

You can run ls -la and remove the largest files in the directory to get your space back.

Additional Information

This issue is resolved in 3.6 and up:

 

Symptom: The dcdebug OnDemand (discovery) log files are not always truncated properly or cleaned up.

Resolution: Completely overhauled dcdebug log cache mechanism.

(3.6.0, DE353560, 00930649,01112122)​