How to debug Performance Management report email failures
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How to debug Performance Management report email failures

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Article ID: 138794

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Reports in Performance Management are sent via email to users. The users report the emails aren't received.

This solution shows how to enable debug for failures related to reports scheduled for email sends.

Environment

All currently supported Performance Management releases

Cause

The debug will help determine if the problem is within the Performance Management product, or the email server receiving and sending the email request.

Resolution

To enable the debug follow these steps:

  1. Go to the following URL. Put the correct PC Hostname or IP address in and if using SSL use the appropriate port. http://PC_HOST:8181/pc/center/admin/debug
  2. Log in using the default admin user and password. Out of the box this is admin:admin.
  3. Select 'Device Manager'.
  4. Select 'Logs'.
  5. Select 'Runtime Configuration'.
  6. Select 'Show All Categories'.
  7. If the below three entries for EmailJobTask, EmailJobScheduler, and EmailJobManager are not found listed, use the 'Add/Update a logging category' option to add each one with the INHERITED level. If already listed move to step 8.
  8. If the entries are already present, or after adding them if required, change the Level for each from INHERITED to TRACE.
  9. Select the Update button found at the top and bottom of the page. Refresh the page to confirm the entries are set to TRACE.
    • com.ca.im.portal.dm.scheduling.email.EmailJobTask
    • com.ca.im.portal.dm.scheduling.email.EmailJobScheduler
    • com.ca.im.portal.api.services.scheduling.email.EmailJobManager

Next reproduce issue trying to send the problem reports via email.

Gather the debug logging by creating diagnostics logging packages. This is done using the CA Remote Engineer (CARE) re.sh script. Run the script on the Performance Management Performance Center web server. Instructions are found below in Additional Information documentation link.

Disable debug by setting the Level values from TRACE back to INHERITED.

Lastly, open a new support case and attach the Performance Center diagnostics logging package for analysis.

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/22-2/troubleshooting/unable-to-resolve-issue.html

Note: This debug would not trace emails sent for Notification Rules triggered from Events.