Workpoint workflow Email notification is not sent in expected language
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Workpoint workflow Email notification is not sent in expected language

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Article ID: 138775

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

After 14.x upgrade from 12.6.x  we noticed that email notification is not triggered for Russian languages which is converted into UTF -8 format in our properties file. 


Environment

Release :

Component : IdentityMinder(Identity Manager)

Jboss/Wildfly

Cause

Changes in Workpoint workflow version from 3.4.2 to 3.5.2 may require configuration changes for mail language conversion.

Resolution

The Workpoint Mail Server configuration needs to specify the correct Content type and the application server needs to have an encoding JAVA Option.



There are  two steps required to get both the Subject and Body to be formatted correctly for EAP’s SMTP Server.



The first step will format the HTML content in the Body of the Email template properly for UTF-8.



1) Update the Workpoint Mail Monitor configuration and set the SmtpContentType to text/html;charset="UTF-8."


       In the wpMonitor.xml being used by the Workpoint Monitors (located within the workpoint-server.properties file)


       Update the SmtpContentType  property as follows:


               text/html;charset="UTF-8"


The second step will properly format the Subject content which is not HTML

2) Update the EAP’s standalone.conf.bat located in the bin directory of your application server. Add the following to file:


            set "JAVA_OPTS=%JAVA_OPTS% -Dfile.encoding=utf-8


NOTE – Make sure the above line Is before this statement

          :JAVA_OPTS_SET