Automate device IP address changes in Performance Management
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Automate device IP address changes in Performance Management

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Article ID: 138674

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

We've identified some devices where the IP address has not been changed in performance center when the IP address has been changed in DNS.

We are able to manually make this change. Is there a way it can be automated?

How to automate IP address changes for devices managed by the DX NetOps Performance Management  Data Aggregator.

We see Data Collector polling issues that appear to start after large scheduled discoveries are run. Sometimes they run without issue. Other times they run, cause polling to stop and the DC must be restarted (dcmd service restart) to resolve the polling problem.

Environment

All supported DX NetOps Performance Management releases

Cause

Managed device IP address changes are not automatically updated by default.

Setting DetectIPChange from false to true, moving around from the default config, on many devices could cause problems with polling. When set to true this will cause the DC to perform DNS name lookups to find new device IP addresses when a managed device's contact status is changed. This would add more network traffic and could cause network performance issues or trigger firewall rules to break communications.

Resolution

To resolve this we can enable an undocumented feature that is disabled by default. It's done per Discovery Profile. The change will automate IP address updates for managed devices.

The only way to manage the features function is through REST calls.

  • Automatic Change Detection:
    • By default, when the IP address that maps to a hostname on the physical device changes, the primary IP on the device item does not change.
    • To update the primary IP automatically, enable IP change detection.
    • Performance Management tries to detect the IP address change only after two consecutive polling failures.
    • The Data Collector (DC) uses a reverse hostname lookup to find the new IP address.
  • NOTE: If DNS is not up to date automatic change detection may cause polling issues post IP change.

To change the features configuration from disabled (DetectIPChange=false) to enabled (DetectIPChange=true) use the following REST based steps.

  • URL to use:
    • <Scheme>://<DA-Host>:<DA_Port>/rest/discoverydefaultconfig/{itemID}
    • Replace with the appropriate value:
      • <Scheme> with http or https
      • <DA-Host> with the DA Host Name or IP address
      • <DA_Port> with the DA port in use. Default = 8581. Recommended HTTPS port is 8582.
      • {itemID} with the Discovery Profile ID that was used to discover the target devices.
        • To find the ID use the URL: <Scheme>://<DA-Host>:<DA_Port>/rest/discoverydefaultconfig
  • Method to set:
    • PUT
  • Content-Type:
    • application/xml
  • Body of call to issue to enable the functionality.
    <DiscoveryDefaultConfig  version="1.0.0">
       <DetectIPChange>true</DetectIPChange>
    </DiscoveryDefaultConfig>
  • Body of call to issue to disable the functionality, the default configuration.
    <DiscoveryDefaultConfig  version="1.0.0">
       <DetectIPChange>false</DetectIPChange>
    </DiscoveryDefaultConfig>

Confirm the changes using a REST GET or by validating 200(OK) responses are seen from the PUT statements.

Additional Information

The ItemID referenced in the URL is not intended to hold the ItemID of a specific device.

This change is a global change performed against the discovery configuration for the system as a whole. The ItemID expected is that of the default discovery configuration entry.