Data collector shows Not Connected in DX NetOps Performance Management
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Data collector shows Not Connected in DX NetOps Performance Management

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Article ID: 138641

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After upgrading my data collector is not showing in the data collector list in DX Netops Portal

After installing the Data Collector the status shows as Not Connected in the DX NetOps Performance Management Data Collector Status view.

After upgrading the Data Collector the status shows as Not Connected and shows the wrong old version in the DX NetOps Performance Management Data Collector Status view.

While examining the logs the only thing seen is the connection request from Data Collector to Data Aggregator in the Data Collector karaf.log file. It errors out with a time out due to no response.

On the Data Aggregator side we see no indication that it received the connection request.

This can also be observed by seeing failures for the communications from Data Collector to Data Aggregator for openwire protocols in a packet capture.

Environment

All supported DX NetOps Performance Management releases

Cause

Firewall rules are blocking ports allowing successful communication between Data Collector and Data Aggregator.

Resolution

There are a few common causes for this problem.

  1. Locally on the Data Aggregator or Data Collector systems we need to ensure the firewalld process is not running.
    • If it is running and is required in the environment, rules must be configured to allow communication between systems for the required ports.
    • To check the status of the firewalld service run:
      • systemctl status firewalld
  2. In the network a firewall outside of the local systems is preventing the communications.
    1. Here again rules must be configured to allow communication between systems for the required ports.

After stopping the firewalld service or resolving the network firewall blocking communications, restart the Data Collector dcmd and activemq services.

  1. service dcmd stop
  2. service activemq stop
  3. service dcmd start

Starting the dcmd process will automatically start the activemq process so there should not be a need to start it manually.

Note that if continued connection issues are observed, try restarting the ActiveMQ service on the Data Aggregator. This can be done without stopping and starting the dadaemon service itself, thus avoiding a sync failure outage in DX Netops Portal. When doing this the dadaemon should restart the ActiveMQ service on it's own within a minute or two if it being stopped. If it does not then a dadaemon restart will be required.

Additional Information