Rally - On-premises: Troubleshooting Email Delivery
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Rally - On-premises: Troubleshooting Email Delivery

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Article ID: 138595

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Updated On:

Products

Rally On-Premise

Issue/Introduction

User can click the Forgot Password link and the system indicates the email is sent, but none is received.


This document outlines some steps that can be taken to understand what might be happening with email delivery in an on-premises appliance.

Cause

In most cases email delivery issues with an on-premise appliance are not due to problems with the server itself, rather they are caused by email servers upstream of the appliance such as corporate email servers.

Resolution

Methods for troubleshooting email delivery will differ between 2018 and lower and 2.0 and higher.

 

2018.1 and lower

You can use the control panel to quickly see the current mail queue size

 

Click "Server Diagnostics" on the left menu

Click the "Email Test" tab  
If the Sendmail Queue shows 0, then there are no emails queued up on the appliance and everything is likely working correctly on the appliance.

If the Sendmail Queue shows a count for Total Requests, it means there are emails not being sent out.

 

The next step is to log into the appliance and look at the mail queue with the following command:

# mailq

 

Sample Output:

/var/spool/mqueue (13 requests)

-----Q-ID----- --Size-- -----Q-Time----- ------------Sender/Recipient-----------

xALHj8g9027567     2775 Thu Nov 21 10:45 <[email protected]>

                 (Deferred: Connection timed out with <MAIL_HOSTNAME>)

<[email protected]>

 

As an example, this output shows that the appliance is having trouble delivering email to the next email server in the path.

 

2.0 and higher

The 2.0 architecture does not include a graphical interface to check the mail queue status so everything must be done from the command line on the appliance

First SSH into the services VM

Next get the docker container ID

$ docker ps | grep _alm

 

Sample Output

a70cee6f347d  <HOST_IP_ADDRESS>:9874/rallysoftware-ac2go-alm:23677-2.0  "run /_run/start_ser…"  About an hour ago  Up About an hour  7001/tcp  repl75895551_alm.1.r7wpk7uzy6jpal6czt5kih2xk

 

Get the container ID as highlighted in yellow above and use it to check the logs on the container

$ docker logs a70cee6f347d 2>&1 | grep EmailNotificationExceptionLogger

OR to find an email address

$ docker logs a70cee6f347d 2>&1 | grep <[email protected]>

 

Sample Output

2019-11-21 02:05:04,129 ERROR [EmailNotificationExceptionLogger] - Valid address, but failed to send to recipient: [email protected]: 450 4.1.2 <[email protected]>: Recipient address rejected: Domain not found

 

In the example above, the email server wasn't able to find the domain starfleet.gov so the email address should be verified.

 

Another method to check email logs is as follows:

$ docker ps | grep smtp

 

Sample Output:

60d16cea6b5a        <HOST_IP_ADDRESS>:9874/rallysoftware-ac2go-smtp:1.0.2-2.1.0            "/_run/start_service…"   3 weeks ago         Up 3 weeks          25/tcp                                        replaa4ee164_smtp.1.36943edaesocmvngrweyc6aed

Once again take the container ID highlighted above and use it in the following command:

$ docker exec -it 60d16cea6b5a bash

 

This is like SSHing into a docker container and puts you at the docker container's terminal prompt.

# cd /mnt/logs/smtp

 

From here you can examine the postfix mail logs, for example:

# less postfix.log

or

# grep -i [email protected] postfix.log