Scheduled Reports Or Dashboard E-mails Not Sent To Recipient
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Scheduled Reports Or Dashboard E-mails Not Sent To Recipient

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Article ID: 138409

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

E-mails are no longer sent to recipient(s).   The SMTP settings in CAPC are correct and sending a test e-mail using telnet from the CAPC server works OK.

Environment

CA Performance Management all releases

Cause

The cause in this example was the CAPC server was unable to resolve the fully qualified host name.  From the DMservice log (CAPC server) we can see the following error:


------snip------

ERROR | EmailJobTaskThreadPool-Thread-285 | 2019-10-09 08:00:48,858 | com.ca.im.portal.dm.scheduling.email.EmailJobTask                

      | Error sending email: myserver.domain.com

java.net.UnknownHostException: myserver.domain.com

------snip------


As we can see here CAPC is unable to resolve the fully qualified host name, myserver.domain.com.

When you run ping hostname only it works but ping myserver.domain.com fails. 

Resolution

Make sure you can resolve the fully qualified host names.  As in the example above we can see ping fails, therefore DNS records must be updated or update /etc/hosts file to include the fully qualified host name and not just host name.