Rally: Custom Apps using Lookback API may see intermittent timeouts.
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Rally: Custom Apps using Lookback API may see intermittent timeouts.

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Article ID: 138350

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Updated On:

Products

Rally On-Premise Rally SaaS

Issue/Introduction

Rally custom app used for reporting and/or capturing snapshots may have started to fail. The custom apps may start to see intermittent timeouts with Lookback API.

Some may see an error similar to:

Failed to load resource: the server responded with a status of 500() /analytics/v2.0

OR

A problem occurred while processing your query.

 

 

Environment

N/A

Cause


The sort parameter:

sort: {"_ValidFrom":1} 


may be causing the request to slowdown. This is due to the way that the database (where Lookback data is stored) handles sorts on the DB side. The request may be processing, but may not return within the timeout threshold.

Resolution

In the custom app code, instead of using the below or similar code:


sort: {"_ValidFrom":1}





Change the Sort value to null:


Sort: (“ “) 


and retry the request.