Provisioning Server Upgrade 14.1 to 14.3 Fails
search cancel

Provisioning Server Upgrade 14.1 to 14.3 Fails

book

Article ID: 138271

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

During the upgrade of provisioning server, the upgrade fails due to CA Enterprise Common Services 



ProductException: (error code = -1; message="Installing CA Enterprise Common Services failed.")

at com.ca.etrust.install.product.InstallEtrustCommonServices.install(InstallEtrustCommonServices.java:325)

at com.ca.etrust.install.product.InstallEtrustCommonServices.replace(InstallEtrustCommonServices.java:54)

at com.installshield.product.service.product.PureJavaProductServiceImpl.replaceProductAction(PureJavaProductServiceImpl.java:1928)

at com.installshield.product.service.product.PureJavaProductServiceImpl$InstallProduct.getResultForReplaceProductAction(PureJavaProductServiceImpl.java:5429)

at com.installshield.product.service.product.InstallableObjectVisitor.replaceComponent(InstallableObjectVisitor.java:578)

at com.installshield.product.service.product.InstallableObjectVisitor.visitInstallableComponents(InstallableObjectVisitor.java:335)

at com.installshield.product.service.product.InstallableObjectVisitor.visitProductBeans(InstallableObjectVisitor.java:133)

at com.installshield.product.service.product.PureJavaProductServiceImpl$InstallProduct.install(PureJavaProductServiceImpl.java:4563)

at com.installshield.product.service.product.PureJavaProductServiceImpl$Installer.execute(PureJavaProductServiceImpl.java:3758)

at com.installshield.wizard.service.AsynchronousOperation.run(AsynchronousOperation.java:41)

at java.lang.Thread.run(Thread.java:745)


Environment

Release : 14.X

Component : CA IDENTITY SUITE

Cause

The process ECSLOGD.exe is the logging daemon for Enterprise Common Services. This process relies on certain files which can become corrupted, causing the ECSLOGD.exe process to consume an inordinate amount of system resources or take a long time to start the service.

Resolution

There are two files that can become corrupted.  

  • ecslog.dat
  • ecslog.idx

Depending on your system these files are located in: C:\Program Files\CA\SharedComponents\eTrust Common Services\Log


Resolution:


  1. Stop CA Enterprise Common Services
  2. Delete the above mentioned files
  3. Begin the upgrade