Asset job status in waiting and in details "Job Concurrency Limit Exceeded"
search cancel

Asset job status in waiting and in details "Job Concurrency Limit Exceeded"

book

Article ID: 138241

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery CA Client Automation - Patch Manager

Issue/Introduction

An asset job is staying in Waiting Status, then resulting the message "Job Concurrency Limit Exceeded" in job status detail.


Imagine the situation we assigned user asset job to user Computer Group (this group has approx. 15 members). The scheduling is daily. For 14 members the asset job is launching everyday (runs is currently approx. 30). One agent has still waiting status. Reboot has no effect for this one. How to force the job to running?



Environment

Client Automation - All versions

Cause

Job Name:


1. AssetJob_1

2. AssetJob2_


The agent logs show two asset jobs trying to be checked/ran at the same time.


TRC_AMAGENT_0.log:

=================

...

|INFO | Job Name:

|INFO | AssetJob_1

|INFO |

|INFO | Reading Local Job status...

|INFO | Local Status not available, creating...

|INFO | Reading Job status...

...

|INFO | Checking criteria for initiating Job...

|INFO | - Maximum number of runs exceeded.

|INFO | Not all conditions meet, skipping job...

|INFO | Writing Local Status...

...

|INFO | Writing Local Job information

|INFO | OK!

|INFO | Job Name:

|INFO | AssetJob_2

|INFO |

|INFO | Reading Local Job status...

|INFO | Local Status not available, creating...

|INFO | Reading Job status...

...

|INFO | Checking criteria for initiating Job...

|INFO | Once a week check.

...

|INFO | Job Concurrency Limit Exceeded.

|INFO | Writing Local Status...

|INFO | Writing status...

...


Resolution

Apply the following procedures on both jobs (AssetJob_1 and AssetJob_2)

to force them to run:


1. On EM expand DS Explorer > server - Enterprise > Computers and Users > the target group >

(Group Details) > Jobs > Asset Jobs > right click target job > Scheduling...

Confirm and set the following:


On Dependency tab > 'Uncheck' all, including, Job concurrency limit > Allow only

On Miscellaneous tab > 'Check', Unattended > This job is allowed to run unattended

Click OK


Answer 'No' for on the Reinitialize Job, question Do you wish to reinitialize status for

all Assets which are connected to this Job?


See article as reference:


Article Id: 44958 Asset Job is staying in Waiting Status


2. Select the machines (ctrl+c) then change their status to Waiting (it will reset Runs to 0)


3. On the DM that machines are reporting to, expand DS Explorer > server - Enterprise >

Computers and Users > the target group > (Group Details) > Jobs > Asset Jobs > click target job

Wait for the download replication job update the asset job of target machines, with new schedule

and status (Waiting and Runs 0).


4. On DM expand DS Explorer > server - Domain > Computers and Users >

select the target group > on the right panel select the target agents > right click >

Asset Jobs > Activate Job Check > select Re-Collect > OK


5. On DM wait for the collect task of scalability server of target agents to complete

at least two cycles.


6. Check the status of job in DM, then on EM.


These procedures should fix the Job Concurrency Limit Exceeded message.