Unable to access Content Transfer from workstation
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Unable to access Content Transfer from workstation

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Article ID: 138227

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Updated On:

Products

CA Business Service Insight

Issue/Introduction

When trying to access Content Transfer (Oblisync) from a workstation browser, the page does not load, but instead shows the spinning loading indicator indefinitely

The log may show an entry containing an <info> line that starts with one of the following:

  • [CrossDomainError] Arguments: NotFound
  • [HttpWebRequest_WebException_RemoteServer] Arguments: NotFound 

Environment

Release : 8.35 and above

Component : CA Business Service Insight

Cause

These types of issues can occur when there is a mismatch between the address configured in the Content Transfer settings and the address being accessed by the browser


Resolution

Check Content Transfer Server Address Accessibility

  1. Log in to the Business Service Insight application
  2. Click Administration -> Site Settings -> Advanced -> Content Transfer
  3. Copy the address from the Content Transfer Server setting
  4. Ensure that you can access that page from your browser
  5. Output should be XML

If the output is "The XML page cannot be displayed", it may indicate the Oblisync JBOSS service is not running.  Follow the instructions below to restart the JBOSS service.

If the output is "This page can’t be displayed", it may indicate a problem with a firewall and your network team may need to be involved.

If the output is a 404 error then the ObliSyncEAR-1.0.ear file may need to be redeployed.  Follow the instructions below.



Redeploy the ObliSyncEAR-1.0.ear file

Locate your installation folder.  This can be identified via the OG_HOME environment variable via a command prompt:

set | findstr OG_HOME

OG_HOME=C:\Program Files (x86)\CA\Cloud Insight

  1. Open a File Explorer window and navigate to the folder identified above.
  2. Then navigate into bin\java-deployments\oblisync
  3. Locate the ObliSyncEAR-1.0.ear.  It will contain an extension of either .deployed or .undeployed.
  4. Delete this file.
  5. If it comes back as ObliSyncEAR-1.0.ear.undeployed, delete that file
  6. You should see the file come back as ObliSyncEAR-1.0.ear.isdeploying followed shortly by ObliSyncEAR-1.0.ear.deployed



Restart the JBOSS Service

  1. Open the services administrative applet
  2. Locate the Oblicore - Oblisync on JBOSS Application Server service
  3. Right click on the service and click Restart



Ensure correct hostname

Silverlight can have difficulties if the hostnames do not match as this will cause issues with cross origin resource sharing.  Ensure that you are accessing the application using the same hostname/IP address as is configured in the Content Transfer Server settings above.  If the hostname needs to be changed, it can be done in in the Content Transfer Server settings above.  You will then need to follow the directions to redeploy the ObliSyncEAR-1.0.ear file and restart the JBOSS service.