No new events are coming from CA Performance Management integration
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No new events are coming from CA Performance Management integration

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Article ID: 138148

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

There are no alarms from CA PM in CA Spectrum OneClick Console.

 

The following errors were found in the Tomcat's log file:

Oct 03, 2019 09:16:14.347 (PoolThread-2587: GlobalPool => RubiconEventPoller) (NetqosEventLog) - (DEBUG) - RubiconEventPoller: Starting event poll for landscape xxxxx79(0x300000)

Oct 03, 2019 09:16:14.347 (PoolThread-2587: GlobalPool => RubiconEventPoller) (NetqosEventLog) - (DEBUG) - No DB value for MaxEventLookbackInDays in DB, using injected default value

Oct 03, 2019 09:16:14.347 (PoolThread-2587: GlobalPool => RubiconEventPoller) (NetqosEventLog) - (DEBUG) - No DB value for MaxEventPollRangeInMS in DB, using injected default value

Oct 03, 2019 09:16:14.347 (PoolThread-2587: GlobalPool => RubiconEventPoller) (NetqosEventLog) - (DEBUG) - RubiconEventPoller (xxxxx79(0x300000)) Starting event collection with start timestamp 1570050049 and end timestamp 1570104974

Oct 03, 2019 09:16:14.362 (PoolThread-2587: GlobalPool => RubiconEventPoller) (NetqosEventLog) - (ERROR) - RubiconEventPoller (xxxxx79(0x300000)) Failed to retrieve events:

Caused by: org.apache.axis2.AxisFault: StatementCallback; uncategorized SQLException for SQL [SELECT ItemTypeName FROM items WHERE ItemID=5122049]; SQL state [HY000]; error code [144]; Table './em/items' is marked as crashed and last (automatic?) repair failed; nested exception is java.sql.SQLException: Table './em/items' is marked as crashed and last (automatic?) repair failed

 at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:508)

 at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:368)

 at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:414)

 at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:225)

 at org.apache.axis2.client.OperationClient.execute(OperationClient.java:150)

 at com.netqos.nqevents.eventmanager.client.EventManagerWSStub.getEventListOrUpdatesWithAllProperties(EventManagerWSStub.java:450)

 at com.ca.im.netqos.integration.event.poller.EventPollerBase.getEvents(EventPollerBase.java:220)

 at com.ca.im.netqos.integration.event.poller.RubiconEventPoller.pollForEventsOnLandscape(RubiconEventPoller.java:117)

 at com.ca.im.netqos.integration.event.poller.EventPollerBase.performTask(EventPollerBase.java:492)

 at com.aprisma.util.thread.ThreadPoolMonitor$TimedThreadTask.performTask(ThreadPoolMonitor.java:135)

 at com.aprisma.util.thread.CachedThread.run(CachedThread.java:116)

Environment

Release : 10.2

Component : Spectrum Integrations

Cause

The items table of em database on the CA PM machine is corrupted.

Resolution

Run the following syntax to repair the items table in the em database:

mysqlcheck --repair -unetqos -pnetqos em items


The items table was successfully repaired.


This is the syntax to check all table from the em database:

mysqlcheck --repair -unetqos -pnetqos em