VSE products, upgrading to z/VSE 6.2 ; we deliver fixes in two formats
search cancel

VSE products, upgrading to z/VSE 6.2 ; we deliver fixes in two formats

book

Article ID: 138018

calendar_today

Updated On:

Products

Dynam for VSE Dynam VSE Option

Issue/Introduction

Site upgrading z/VSE and asking about compatibility with VSE products.

Environment

Release : 7.1

Component : CA-Dynam for VM

Cause

Site upgrading z/VSE and asking about compatibility with VSE products..

Resolution

We deliver fixes for our products in two formats.


1.  The old way - using MSHP CORRECT. e.g.


CORR 0202-SAD-01-VS3:RO02945 
AFF  PHASE=CASSNAPA          
ALT  0002F4 4370105B:BF73105A
ALT  00035A 427052A2:BE7352A2



2.  The preferred way now - as a modrep using MSHP APPLY e.g.


APPLY 0202-CCI-01-VS2:RO03057                                          
RESO     'CCIVSE abends at startup W/SYSDEF SYSTEM,NTASKS > 255'      -
   APARS=(RO03057,TE49752,LO99483,QO11603,LO29297,LO30499,LO43659,    -
          QO11606,QO65199,QO87395,TE49332,TH00781,TE49097,TE49159,    -
          TE49195,TH00785,TE49517,TE49462)                             
REQ  PRE=(QO11602,LO29200,LO50464,QO11607)                             
SUP      (TE49752,LO99483,QO11603,LO29297,LO30499,LO43659,QO11606,    -
          QO65199,QO87395,TE49332,TH00781,TE49097,TE49159,TE49195,    -
          TH00785,TE49517,TE49462)                                     
AFF   PHASE=CA3CINIT                                                   
AFF   PHASE=CA3C$SVA                                                   
DATA                                                                   
++IMBED CA3CINIT PHASE *                                               
++IMBED CA3C$SVA PHASE *                                               
/$              
                                                       



In the first case the fix is logged in the history file as an APAR.  In the second case as a PTF.  This is why LOOKUP PTF = RO02945 fails but LOOKUP PTF = RO03057 succeeds. RO02945 is an APAR not a PTF.  The customer could use LOOKUP APAR=RO02945.  


However when we create a service pack, fixes that were apars will be archived in a new history file as PTFs.  So my advice to all is don't use LOOKUP, do use RETRACE to determine if service has been applied.