Spectrum "FAILURE TO BIND TO A TRAP PORT" alarm on VNM model
search cancel

Spectrum "FAILURE TO BIND TO A TRAP PORT" alarm on VNM model

book

Article ID: 138017

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Spectrum "FAILURE TO BIND TO A TRAP PORT" alarm on VNM model - Cause Code: 0x10e05

Environment

Release : Any Spectrum version

Component : Spectrum Core / SpectroSERVER

Cause


There is another process that is bound to the default trap port 162 preventing Spectrum from binding to the trap port for trap processing.

Resolution


On Linux, check to see if the snmptrapd process is running. If so, stop this process and prevent it from restarting and then restart the SpectroSERVER process.


  - netstat can be used to see what process has port 162 bound (requires root to see the process info)

# netstat -anp | grep 162
udp        0      0 0.0.0.0:162             0.0.0.0:*                           1336/snmptrapd

systemctl stop snmptrapd
systemctl disable snmptrapd

Restart the SpectroSERVER as the spectrum user.

 

On Windows, check to see if the SNMP Trap service is running. If so, stop the service and prevent it from restarting and then restart the SpectroSERVER process.


- Start a bash shell by running "bash -login"

- Run the following command to display the process id and name of the process that is bound to port 162:

netstat -ano | grep 162

udp6       0      0 :::162                  :::*                                1234/snmptrap.exe



Use the Windows Services Control Panel (services.msc) to stop 'SNMP Trap' and set it to manual or disabled


- Restart the SpectroSERVER after stopping the 'SNMP Trap' service or other applications using the port.

 

The SpectroSERVER application is listening on port 162:

Additional Information

The most common root cause is that the Secure Domain Connector was installed on the SpectroSERVER machine.

The following KB article provides the steps to uninstall the Secure Domain Connnector.

https://knowledge.broadcom.com/external/article?articleId=196089