Virtual Network Assurance installation fails due to permissions problems
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Virtual Network Assurance installation fails due to permissions problems

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Article ID: 137738

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Updated On:

Products

CA Virtual Network Assurance CA Performance Management - Usage and Administration

Issue/Introduction

During installation of the Virtual Network Assurance (VNA) product, despite use of the root user, the install may show a failure during home path creation and exit.


Errors seen during the install failure would look similar to:


Please enter an absolute path to install (default install folder /opt/CA)>

/opt/CA

Error: Insufficient permissions for installation path: /opt/CA

Path must have executable permission for 'other'.

Exiting the installer...


Environment

All supported releases of CA Virtual Network Assurance For CA Performance Management

Cause

The root users umask setting is not set to a value that allows for the creation of directories or files with Other user read and write permissions.


The install is able to create the directory but without the correct Other user access for the Wildfly user, the install fails to move forward and complete.

Resolution

Set the root user umask to 0022 using the following command run as the root user.

  • umask 0022


Next run the following command to confirm the setting. Is in place:

  • umask


The failure still creates the install home directory specified with the wrong permissions. Delete that directory structure. In the example error above, to delete the /opt/CA directory we'd use the following command.

  • rm -rf /opt/CA


With umask set correctly and the problem directory deleted, rerun the installation.

Additional Information

This will be resolved in a future VNA release via a defect. This article will be updated regarding release version with fix when that is determined.