Data collector showing unknown status in DX Netops Portal.
search cancel

Data collector showing unknown status in DX Netops Portal.

book

Article ID: 137676

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

 Due to OS patch install, the DX NetOps Performance Management  servers are restarted. However, the Data Collector (DC) is showing unknown status in the DX Netops Portal,

The following error in the file is shown:

/opt/IMDataCollector/apache-karaf-2.4.3/data/log/karaf.log


2019-09-25 21:57:35,287 | WARN  | Event Dispatcher | AetherBasedResolver              | mvn.internal.AetherBasedResolver  583 | 3 - org.ops4j.pax.logging.pax-logging-api - 1.8.3 |  | Error resolving artifactcom.ca.im:data-mgmt.provision:xml:features:3.7.0-RELEASE-355:Could not find artifact com.ca.im:data-mgmt.provision:xml:features:3.7.0-RELEASE-355 shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Could not find artifact com.ca.im:data-mgmt.provision:xml:features:3.7.0-RELEASE-355

 

Environment

Dx NetOps Performance Management any version

 

Cause

The following directory is missing or corrupted:

/opt/IMDataCollectyor/.maven_repository 

Resolution

Reinstall the Data Collector

Additional Information

The Data Collector can be installed over itself. You should not uninstall and reinstall

See the following documentation for installation instructions:

Data Collector Installation Instructions