Unable to select a field to add to a form in Identity Portal - the field is not listed.
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Unable to select a field to add to a form in Identity Portal - the field is not listed.

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Article ID: 137630

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Updated On:

Products

CA Identity Manager CA Identity Portal CA Identity Suite

Issue/Introduction

When creating a form in Identity Portal, the IM attribute we wish to add to to a form isn't available to select.  Specifically, for the Forgotten User ID task, %EMAIL% is not available as an attribute to add to the form properties.  How can this be accomplished?

Environment

Release : 14.x

Component : SIGMA-Identity Suite

Cause

This is because Identity Portal pulls the fields from the Profile screen on the underlying Identity Manager admin task's Tabs tab.  The OOTB Forgotten User ID task uses a profile screen, ForgottenUserID, which is not editable and doesn't contain fields which Identity Portal can use.

Resolution

Adding a hidden screen with the necessary field can be done as follows.  Using Forgotten User ID as an example:


1. In Identity Manager, edit the Forgotten User ID task.

2. Go to the Tabs tab and add a new screen of type "Profile (UserProfile)".

3. Click the edit icon to edit the new screen.

4. In the Screen field, browse and select the "Forgotten User ID Identify" screen.

5. Click the Hide Tab box above the Screen field so the tab is hidden.

6. Save the changes to the task.


If you test the task in Identity Manager now, it should behave in the same way as before this change.


Next, go to Identity Portal Management console and create a form to be used by the Forgotten User ID task.  You should now be able to select the %EMAIL% field on the form properties (you may need to restart the CAIM connector first).


Additional Information

Forgotten User ID is a public task, only available for use in Identity Portal from 14.2 onward.  However this procedure can be used for any task where the OOTB profile screen doesn't have the needed attributes or can't be edited.