ERROR: Timeout waiting for CA ControlMinder daemon to start
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ERROR: Timeout waiting for CA ControlMinder daemon to start

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Article ID: 137446

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Updated On:

Products

CA Privileged Identity Management Endpoint (PIM) CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

When we try to start PIM we get the following message :


#/opt/CA/AccessControl/bin/seload

CA ControlMinder seload v12.81.0.3339 - Loader Utility        

Copyright (c) 2013 CA. All rights reserved.

12 Sep 2019 12:00:45> WAKE_UP : Server going up

12 Sep 2019 12:00:45> INFO    : Filter mask: 'WATCHDOG*' is registered

12 Sep 2019 12:00:45> INFO    : Filter mask: 'INFO    : Setting PV*' is registered

12 Sep 2019 12:00:45> INFO    : Filter mask: 'INFO    : DB*' is registered

12 Sep 2019 12:00:45> INFO    : Filter mask: '*seosd.trace*' is registered

12 Sep 2019 12:00:45> INFO    : Filter mask: '*FILE*secons*(*/log/*)*' is registered

Starting seosd. PID = 32091.

Checking database ...

ERROR: Timeout waiting for CA ControlMinder daemon.


Additional info:

# /opt/CA/AccessControl/bin/issec


CA ControlMinder kernel extension is loaded.

CA ControlMinder daemons are not running.

CA ControlMinder security daemon is not running.

CA ControlMinder watchdog daemon is not running.

CA ControlMinder agent daemon is not running.

CA ControlMinder serevu daemon is not running.

CA ControlMinder selogrd daemon is not running.

CA ControlMinder selogrcd daemon is not running.

CA ControlMinder eacws daemon is not running.

CA ControlMinder ReportAgent daemon is not running.

CA ControlMinder AgentManager daemon is not running.

CA ControlMinder policyfetcher daemon is not running.

CA ControlMinder KBLAudMgr daemon is not running.

CA ControlMinder auxiliary daemon is not running.


*******************

in messages log  we see the error

 SEAGENT[26628]: In catch - signal 15



Environment

Privleged Identity Manager 12.8 sp1 /PAMSC

VeRsIoN: 12.81-0 (3339)  

Linux 

Cause

This may be caused by a database corruption.

Resolution



Rebuild the database and export/import rules in a seosdb one.


Stop Access Control if it's running

# secons -s

Make a backup that you won't touch

# cp -R /opt/CA/AccessControl/seosdb /backup/location

Change into your seosdb directory

# cd /opt/CA/AccessControl/seosdb

Close the database, in case it's still open:

# dbmgr -u -close

Check the database:

# dbmgr -u -check

If there are no errors, rebuild the database files using the following commands:


dbmgr -u -build seos_cdf.dat

dbmgr -u -build seos_pdf.dat

dbmgr -u -build seos_pvf.dat

dbmgr -u -build seos_odf.dat

If every thing goes fine without any error messages, please start Access Control.


BUT --


If the dbmgr -u -check gives an error, or there are errors with the -build command on the database files, or seosd does not start properly, perform the following:



  • Create another backup of the old database that we can operate on. You can remove this after the test



# cp -R /opt/CA/AccessControl/seosdb /opt/CA/AccessControl/seosdb.tmp


Create a script that will duplicate the ruleset by running the dbmgr utility on the temp database:


# cd /opt/CA/AccessControl/seosdb.tmp

# dbmgr -export -l -f /tmp/lang_script

Create a new database over your current one.


# cd /opt/CA/AccessControl/seosdb

# dbmgr -c -cq

Import the script generated previously to populate the new database:


# cd /opt/CA/AccessControl/seosdb

# selang -l -f /tmp/lang_script

Execute the dbmgr utility to create a flat file containing data from the old database:


# cd /opt/CA/AccessControl/seosdb.tmp

# dbmgr -migrate -r /tmp/flat_file

Load the data from the flat file into the new Access Control database:


# cd /opt/CA/AccessControl/seosdb

# dbmgr -migrate -w /tmp/flat_file

This should allow Access Control to start again.