Client Automation - Asset Collector stops collecting xiu files
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Client Automation - Asset Collector stops collecting xiu files

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Article ID: 137201

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Asset Collector stops collecting xiu files.


Following lines are seen in the logs TRC_ASSETCOLLECTOR_*.log just before hang problem


AssetColle|cfFTClientAPI | |000000|INFO | StartFileTransfer() - filename:C:\WINDOWS\TEMP\9E3BBE3A-7F80-41F3-8D37-22C14348B897.COL

AssetColle|cfFTClientAPI | |000000|INFO | StartFileTransfer() - guid:B69E9315-0B13-47E2-AC23-7E01FAEB5B9F

AssetColle|cfFTClientAPI | |000000|INFO | StartFileTransfer() - file is an upload

AssetColle|cfFTClientAPI | |000000|INFO | Starting upload




And Following error is seen in the logs TRC_CF_FTPLUGIN_*.log at the same time :


cfFTPlugin | |000000|ERROR | Server - Failed to open file C:\Program Files(x86)\CA\DSM\ServerDB\SECTOR\\COLLECT\AUDIT\9E3BBE3A-7F80-41F3-8D37-22C14348B897.COL




Environment

Release : 14.*

Component : Client Automation




Cause

The error indicates that asset collector hangs when trying to upload the file 9E3BBE3A-7F80-41F3-8D37-22C14348B897.COL in C:\Program Files (x86)\CA\DSM\ServerDB\SECTOR\\COLLECT\AUDIT.

This could be caused by missing directory C:\Program Files (x86)\CA\DSM\ServerDB\SECTOR\COLLECT\AUDIT






Resolution

Create manually the directory C:\Program Files (x86)\CA\DSM\ServerDB\SECTOR\\COLLECT\AUDIT