We are receiving from AlarmNotifier "No event format file exists"
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We are receiving from AlarmNotifier "No event format file exists"

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Article ID: 137195

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When starting Alarm Notifier and seeing either in the Notifier.OUT or in the sent emailed alarms you may see under Event Message "An event occurred for model "xxx" of type "yyy" for which no event format file exists. (event <event code>)

Environment

Release : 10.3

Component : Spectrum Core / SpectroSERVER

Cause

This can be caused if Custom Events are created and no Event Message is created at the time the Custom Event is created.

This can also be caused by not having the CsEVFormat files copied from OneClick to the server where AlarmNotifier is running.

When a custom event is created in EcEditor, we save a copy of AlertMap and EventDisp files in the custom directory on the SS and save the Pcause and EvFormat files on the OneClick server, If the customer uses Alarm Notifier though,  the Pcause and EvFormat files would also have to reside on the SpectroSERVER so Alarm Notifier can process them.

On the SpectroSERVER there are 3 possible locations where Pcause/EvFormat files may be stored are:

$SPECROOT/SG-Support/CsEvFormat

$SPECROOT/SG-Support/CsPCause

$SPECROOT/Custom/event/CsEvFormat

$SPECROOT/Custom/event/CsPCause

$SPECROOT/Custom/CsEvFormat 

$SPECROOT/Custom/CsPCause

 

I have checked through the docs and it is briefly mentioned

If you use the Command Line Interface (CLI) commands show alarms or show events, or SPECTRUM Alarm Notification Manager (SANM), then you will want to copy the contents of these three directories to all SpectroSERVERs in <$SPECROOT>/SG-Support.

However, due to the risk of custom files getting overwritten they should be placed into one of the two custom directories mentioned previously.

In checking further it doesn't matter if your custom PCause files from OneClick are in $SPECROOT/Custom/event/CsPCause or $SPECROOT/Custom/CsPCause as Alarm Notifier searches all three of these locations.

 

The search order is controlled by these two files ssroe_alrm_en_US.prf for pcause and ssroe_evnt_en_US.prf for EvFormat files.

$SPECROOT/SG-Support/CsResource/preferences

$ cat ssroe_alrm_en_US.prf

(ssroe_alarm_pref CsUserPreference

    (probableCauseDir CsStringPreference

        probableCauseDir = "C:/win32app/SPECTRUM/custom/CsPCause;C:/win32app/SPE

CTRUM/custom/Events/CsPCause;C:/win32app/SPECTRUM/SG-Support/CsPCause"

    )

)

 

$SPECROOT/SG-Support/CsResource/preferences

$ cat  ssroe_evnt_en_US.prf 

(ssroe_event_pref CsUserPreference

    (eventFormatDir CsStringPreference

        eventFormatDir = "C:/win32app/SPECTRUM/custom/CsEvFormat;C:/win32app/SPE

CTRUM/custom/Events/CsEvFormat;C:/win32app/SPECTRUM/SG-Support/CsEvFormat"

    )

)

Resolution

If the customer copies the custom pcause and EvFormat files from the OneClick server to the SpectroSERVER to any one of the two custom locations then AlarmNotifier should be able to use these custom pcause files.

If this does not resolve the problem please check the exact pathing for the eventFormatDir and make sure that it is completely pathed out and not using an Environmental Variable

Additional Information

 

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/spectrum/23-3/managing-network/event-configuration/getting-started-with-event-configuration.html