MSM - HttpResponseException when updating Maintenance
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MSM - HttpResponseException when updating Maintenance

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Article ID: 137030

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Updated On:

Products

CHORUS SOFTWARE MANAGER

Issue/Introduction

We have been experiencing an issue with pulling in maintenance using the Chorus product. We've been doing choosing the "Upgrade CA RS Level" Option. The task that Failed is "1449 - Quick Product/Release Maintenance Information". The contents of the error log are:


org.apache.http.client.HttpResponseException: Unauthorized

at org.apache.http.impl.client.BasicResponseHandler.handleResponse(BasicResponseHandler.java:68)

at org.apache.http.impl.client.BasicResponseHandler.handleResponse(BasicResponseHandler.java:54)

at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:1070)

at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:1044)

at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:1035)

at com.ca.mf20.SAM.WSinterface.QuickGetPTFS.getSysmodsList(QuickGetPTFS.java:111)

at com.ca.mf20.SAM.ProcessComponentAPARS.getAPARlists(ProcessComponentAPARS.java:172)

at com.ca.mf20.SAM.Commands.QuickRelUpdateCmd.execute(QuickRelUpdateCmd.java:236)

at com.ca.mf20.tasks.commands.AbstractCommand.execute(AbstractCommand.java:312)

at com.ca.mf20.tasks.tasks.Task.executeCommand(Task.java:725)

at com.ca.mf20.tasks.tasks.Task.executeCommandList(Task.java:597)

at com.ca.mf20.tasks.tasks.Task.execute(Task.java:494)

at com.ca.mf20.tasks.tasks.TaskManager$RunnableMSMTask.run(TaskManager.java:480)

at com.ca.mf20.zos.services.security.SecurityThreadFactory$SecurityRunnable.run(SecurityThreadFactory.java:53)

at java.lang.Thread.run(Thread.java:809)


And the contents of the information log are:

1449 - Quick Product/Release Maintenance Information    - Started September 10, 2019 11:36:00 AM CDT

Request is to get release: 20.0

              for product: CA RC/Query for DB2 for z/OS - MVS

           using site IDs: 999999



  NOTE: No product packages are retrieved with this update. Only maintenance will be retrieved.

 There are 48 components associated with this product.


Maintenance for component CA Report Facility for DB2 for z/OS processing completed.

  Maintenance returned: 49 - 0 inserted, 49 already existed, 0 non-z/OS skipped, 0 withdrawn.


Maintenance for component CA Resource Initialization Manager(Comm) processing completed.

  Maintenance returned: 4 - 0 inserted, 4 already existed, 0 non-z/OS skipped, 0 withdrawn.


Maintenance for component CA Fast Load for DB2 for z/OS processing completed.

  Maintenance returned: 29 - 0 inserted, 29 already existed, 0 non-z/OS skipped, 0 withdrawn.



Processing completed, but errors have occured

     Elapsed seconds: 597



Environment

Release : 6.0

Component : MSM PRODUCT ACQUISITION SERVICE

Cause

Intermittent internal server error 

Resolution

This error is chiefly due to an internal error from our supportservices servers. If this happens you should try rerunning the job and it most likely will be successful. If you consistently receive the same error over several attempts please open a MSM support case via the https://casupport.broadcom.com Support Portal