Rally - Quick Filters Removed from Saved Views
search cancel

Rally - Quick Filters Removed from Saved Views

book

Article ID: 136914

calendar_today

Updated On:

Products

Rally SaaS

Issue/Introduction

Views that previously contained the default quick filters in addition to advanced filters may find that the quick filters are now missing if they were empty previously.  



This may break custom filter logic such as "(3 AND 4) OR (5 AND 6)" since the 1 and 2 specifically referenced the quick filter fields as shown above.



With the removal of the the quick filter fields, the custom filter logic becomes invalid as the advanced fields have been renumbered starting with 1, however the custom filter logic still references the original numbering


Environment

Release : SAAS

Component : AGILE CENTRAL

Cause

This behavior is a byproduct of a fix for a problem where the default quick filters in saved views kept returning even though the view had been saved without them.  Now when a new view is created, those fields will appear until they are removed and a view saved without them, however if you had worked around that issue by including the default fields in your view that didn’t have values, then they were removed by this change.

Resolution

To resolve this issue, it will be necessary to renumber the field numbers in your custom field logic to reference the updated field numbers.