Upgrading Clarity fails when applying PPM_INVALID_USER.xml
search cancel

Upgrading Clarity fails when applying PPM_INVALID_USER.xml

book

Article ID: 136674

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Upgrading Clarity fails when applying PPM_INVALID_USER.xml 

4/25/24 8:49 AM (ExecTask) Error Applying XOG: Failure occurred while applying PPM_INVALID_USER.xml
4/25/24 8:49 AM (ExecTask)  Check D:\clarity/logs/xog-seeddata/out/infrastructure\PPM_INVALID_USER_out.xml for errors
4/25/24 8:49 AM (ExecTask) D:\clarity\.setup\scripts\db.xml:2742: The following error occurred while executing this line:

4/25/24 12:06 PM (ExecTask)     Applying resources/xc_admin.xml
4/25/24 12:06 PM (ExecTask) 12:06:01.455 [main] ERROR com.niku.xql2 - Failure while evaluating "integer($resuserid) != -99" in expression "{integer($resuserid) != -99}"
4/25/24 12:06 PM (ExecTask) java.lang.Exception: Invalid expression integer($resuserid) != -99: Error parsing number -99

Cause

The OS regional settings of the application server are not set to English (United States)

Resolution

Please ensure the locale settings of the application server are set to English (United States)