SOAP Queries from PX Action elements fail with a NullPointerException after upgrading to Identity Manager 14.2 CP4
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SOAP Queries from PX Action elements fail with a NullPointerException after upgrading to Identity Manager 14.2 CP4

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Article ID: 136663

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

I have recently applied CP4 on my Identity Manager 14.2 and when testing the SOAP Query of Policy Xpress (PX) policy Action rule, the following error appears on screen:

  "Failed running web service " which was caused by "null"

or

  "Failed running web service " which was caused by "Could not send Message.;HTTP response '403: Forbidden' when communicating with http://idm.example.com/iam/im/TEWS6/identityEnv?wsdl"


Application server log shows the following exception:

2019-06-24 12:36:40,084 ERROR [com.netegrity.ims.exception.EventExecuteStateException] (Thread-43 (HornetQ-client-global-threads-1367790804)) Exception: : java.lang.NullPointerException

at java.util.concurrent.ConcurrentHashMap.putVal(ConcurrentHashMap.java:1011) [rt.jar:1.8.0_71]

at java.util.concurrent.ConcurrentHashMap.put(ConcurrentHashMap.java:1006) [rt.jar:1.8.0_71]

at org.apache.cxf.jaxws.context.WrappedMessageContext.put(WrappedMessageContext.java:455)

at org.apache.cxf.jaxws.context.WrappedMessageContext.put(WrappedMessageContext.java:416)

at org.apache.cxf.jaxws.context.WrappedMessageContext.put(WrappedMessageContext.java:46)

at com.ca.identitymanager.policyxpress.tools.WebserviceUtils.setSOAPHTTPHeader(WebserviceUtils.java:777) [identitymanager.jar:]

at com.ca.identitymanager.policyxpress.tools.WebserviceUtils.getWSDispatch(WebserviceUtils.java:186) [identitymanager.jar:]

at com.ca.identitymanager.policyxpress.plugins.events.ExecuteSoapWebserviceEvent.execute(ExecuteSoapWebserviceEvent.java:66) [identitymanager.jar:]

        ...


Here is the configuration PX Policy's Action that sends the SOAP Query

   Name : Call SOAP Call

   Category : SOAP Queries

   Type : SOAP Query

   Function : Basic Auth Invoke

   

   WSDL URL: http://idm.example.com/iam/im/TEWS6/identityEnv?wsdl

   User Name: imadmin

   Password: *****

   SOAP Action: <empty>

   SOAP Version: 1.1


   SOAP Request Message:

   

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsdl="http://tews6/wsdl">

   <soapenv:Header/>

   <soapenv:Body>

      <wsdl:TaskContext>

         <!--You may enter the following 11 items in any order-->

         <!--Optional:-->

         <wsdl:admin_id>imadmin</wsdl:admin_id>

         <!--Optional:-->

         <wsdl:admin_password>Password01</wsdl:admin_password>

      </wsdl:TaskContext>

      <wsdl:ModifyUser>

         <wsdl:ModifyUserSearch>

            <wsdl:Filter index="0">

               <wsdl:Field>%USER_ID%</wsdl:Field>

               <wsdl:Op>EQUALS</wsdl:Op>

               <wsdl:Value>user1</wsdl:Value>

            </wsdl:Filter>

         </wsdl:ModifyUserSearch>

         <!--Optional:-->

         <wsdl:ModifyUserProfileTab>

            <wsdl:title>Manager</wsdl:title>

         </wsdl:ModifyUserProfileTab>

      </wsdl:ModifyUser>

   </soapenv:Body>

</soapenv:Envelope>


The same SOAP request when executed via SOAP UI tool is successful. Before upgrade to CP4 the PX policy worked normally.


Environment

Release: 14.2 CP4


Component: Identity Manager

Cause

This is a known bug which is recorded as DE429142

Resolution

Please raise a Technical Support ticket and request for DE429142 hot-fix to address this issue.

At the time this article is created, CP4 is the latest cumulative patch for 14.2. If later CP version is available now, please check Release Notes of the CP and confirm if DE429142 is fixed. If so, apply the CP to address the issue.