I am getting a PAM-UI-1003: Service Unavailable after upgrading
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I am getting a PAM-UI-1003: Service Unavailable after upgrading

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Article ID: 136635

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Periodically PAM Users get the following error messages in the UI:

PAM-UI-1003: Service Unavailable

On closing this message, some of the symptoms which may occur are:

  • The Config tab is empty and it does not show any option
  • The access page is empty or it fails to list all devices
  • No policies are available, or sometimes they are available and sometimes they are not
  • The user gets kicked out of the console and he needs to log in again

When looking over the logs, there is nothing that indicates what may be happening. Disk, CPU and RAM usage, as per the Dashboard, look normal.

Environment

Privileged Access Manager 3.4.x, 4.0.x, 4.1.x

Cause

This issue occurs if pam appliance is running with lower resources than what our product recommends.

In every release from PAM 3.4.x, 4.0.x and 4.1.x, we document the following resources:

  • Privileged Access Manager provides virtual images as VMware OVA, AWS AMI, and Azure VHD. When you provision these instances, we recommend the following parameters: Memory: 64 GB
    CPU: 8 cores (we support up to 512 CPU cores)
    Storage: 80 GB
    Disk Type: SSD
  • At a minimum, we require the following parameters:
    Memory: 16 GB
    CPU: 8 cores (we support up to 512 CPU cores)
    Storage: 80 GB
    Disk Type: SSD

 

Resolution

The best way to resolve this problem is upgrade the system to our recommended resources.