Maximum Lines revert back after changing them in profile
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Maximum Lines revert back after changing them in profile

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Article ID: 136631

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Updated On:

Products

Roscoe

Issue/Introduction

We noticed an issue last week where a user had 50,000 maximum number of lines allowed in their Library.

They asked for it to be increased.  We did so by changing it to 100,000.

The next day, it had reverted back to the 50,000 max.   We do cycle all the regions every night.

Why would it revert back?


We always use the UPS.UPSMNT60 to make these kind of changes.


Does the user have to be logged off in order for the change to be permanent?


Environment

Release : 6.0

Component : CA Roscoe Interactive Environment

Cause


Roscoe stores the changes (for this option anyway) in the users "buffer" profile entry. If the changes are made when they are active, the change is in temporary storage and not written back to the profile.


If the user is not active, then the update is not in the "buffers'" but in the actual profile entry at startup, therefore permanent.


Resolution

Run UPS.UPSMNT60 from the ROSCOE.PROFILE (UPS) key (or from your own key if you have UPS authority). Update the users profile by increasing the MAXIMUM LINES USER CAN SAVE FIELD or set it to 00000000 (no limit). This value is set individually for every user. The user must log off and log on to pick up the new limit after you have updated their profile.  


The answer is YES, the user must be logged off to make the change permanent. 


The reason this is true: Roscoe stores the changes (for this option anyway) in the users "buffer" profile entry. If the changes are made when they are active, the change is in temporary storage and not written back to the profile.


If the user is not active, then the update is not in the "buffers'" but in the actual profile entry at startup, therefore permanent.