Error: 'You do not have permissions for the New User Experience' appears temporarily when accessing New UX Timesheets
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Error: 'You do not have permissions for the New User Experience' appears temporarily when accessing New UX Timesheets

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Article ID: 136576

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Some users report that when they access the New User Experience (UX/UI), they see 'You do not have permissions for the new user experience.' message on the page. It stays for a few seconds and refreshes to the timesheet page. 

Steps to Reproduce:

  1. Create a new user (example: testuser)
  2. Grant Timesheets - Navigate access (ensure they don’t have Project Management – Navigate rights)
  3. Make sure that Activate Timesheets and Activate New User Experience are checked in System Options in Classic Clarity
  4. Log in to the Clarity New UX as the test user using the URL that doesn’t take you to the Timesheets directly: Example: http://<clarityurl>/pm

Expected Results: You are routed directly to the Timesheets section of New UX and no error is shown

Actual Results: You see a page with an error message “You do not have permissions for the new user experience.”, temporarily, and then you are rerouted after a few seconds to the correct timesheet page

Environment

Release : 15.3, 15.4, 15.4.1, 15.5, 15.5.1, 15.6, 15.6.1

Cause

This issue is caused by DE50990. 

Resolution

This issue is no longer reproducible as of 15.6.1 patch 2 and 15.7 patch 1.

Workaround: Wait a few seconds, then you should be routed automatically to the New UX timesheets page